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Getting Started 

Logging on to a SharePoint Site 
1. Open Internet Explorer. IE Version 9 or higher is best, but you can also use Chrome or Firefox. 
2. Type the address of your SharePoint site in the address bar. 
3. Enter your SharePoint username* and password* in the login dialog box. 

 
4. If your account is locked, the dialog box will only “blink” and nothing will happen. Locked accounts 

will automatically reset after 20 minutes; we recommend restarting your browser after 20 minutes 
and re-entering your account credentials. 

5. * If you need to request a SharePoint account, or have any problems logging in to the SharePoint 
site, send an email to dlwebcom_doit@maryland.gov. 

 

Changing your SharePoint Site Password 
1. Navigate to https://pub.maryland.gov/sites/workspace. You can create a browser bookmark for this 

site, or for your convenience, there is usually a link called “Admin Workspace” in the left nav 
column of the root site. 

2. Login again using your SharePoint username and password (this is a different site collection). 
3. Use the CHANGE PASSWORD link in left column. 

 

Create a New Site (Subsite) 
1. You will usually start at the site’s root level to create a subsite – Under Site Actions, select New 

Site. 
2. There are 3 different site templates to choose from; choose carefully – the icons looks the same, 

but the descriptions on the right explain the differences. 
a. Maryland Responsive Site – creates a site/subsite with full banner and gov image on 

homepage 
b. Maryland Responsive NoGov Site – creates a site/subsite with full banner and NO gov 

image on homepage 
c. Maryland Responsive Subsite – creates a subsite with slim banner and no gov image 

on homepage 

mailto:dlwebcom_doit@maryland.gov
https://pub.maryland.gov/sites/workspace
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3. Enter a Title (My Subsite Title) and a URL name (i.e. mysubsite). 
4. Click Create.  
5. Additional information about creating subsites is in the DoIT SharePoint 2010 Responsive Toolkit 

(https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Responsive-Design-Toolkit-User-
Guide.pdf).  

 

Delete a Site (Subsite) 
 
 
 

1. Under  , select Site Settings. 
2. Click Delete this site. Read the steps carefully to remove the site and all of its content. 

 

Grant Permission: Add users to a group 
1. Request a new user account from DoIT Web Systems: firstname, lastname, email address 
2. From   select Site Settings. 
3. Select Site Permissions. 
4. Click on the group name that will receive new members. 
5. Click New, Add Users. 
6. Either type user names or use the address book ( ) to add people to the group. 
7. If you want to send a welcome email with a link to the site in it, verify that Send welcome e-mail 

to new users is checked. 
8. Write a custom message to the new users. 
9. Click . 

Warning: Deleting a site permanently 
deletes the entire contents of the site. 

https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Responsive-Design-Toolkit-User-Guide.pdf
https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Responsive-Design-Toolkit-User-Guide.pdf
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Working with Documents 

Create a New Library 
1. On the Quick Launch Bar, click All Site Content. 
2. Click . 
3. Click on the type of library you want to create. 
4. Enter the name and description. 
5. Click . 

 

Delete a Document 
1. Check the check box next to the document name. 
2. On the Document tab, click  . 
3. Click . 

 

Read a Document 
1. View All Site Content; navigate to a document library. 
2. Click on the name of the document.  

Your document will open read-only or you will be asked if you want to check out the document. 

 

Upload a Single Document 
1. View All Site Content; navigate to a document library. 
2. Select the Documents tab. 

3. Click  
4. Click . 
5. Highlight the desired document. 
6. Click . 
7. Click . 
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Upload Multiple Documents 
(only works with Internet Explorer and MS Office) 
1. Open any Document Library; select the Library Tools > Documents tab. 

2. Click  
3. Click Drag File and Folders, or Browse for files instead. 
4. Highlight the desired documents. 
5. Click . 
6. Click . 

 

Working with Lists 

Create a Custom List 
1. Click Site Actions > View All Site Content. 
2. Click Create. 
3. Click the List tab from the left panel section Filter By. 
4. Select Custom List. 
5. Enter the Name of the new list. 
6. Click More Options. Change the Navigation default to NOT display on the Quick Launch.* 
7. Click Create.        

The list will appear with only the Title column. Use the following steps to add new columns: 
8. Select the List tab. 
9. Click Create Column. 
10. Define the column and click OK. 
 
*If you happen to overlook this step, the default setting will cause the new list to appear in the left 
column under a LISTS heading. To remove this, go to Site Actions > Site Settings > Look and Feel > 
Navigation. Select the Heading/folder icon Lists under Current Navigation and click Delete. Repeat 
this step to Delete the List Name from the Current Navigation. 
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Create a Custom List View 
1. In your library or list, select the List or the Library tab. 

2. Click on . 
3. Select the desired view type. 
4. Enter the choices for your view. 
5. Click . 

 

Create a List from an Excel Spreadsheet 
1. Click Site Actions > View All Site Content. 
2. Click Create. 
3. Click the List tab from the left panel section Filter By. 
4. Select Import Spreadsheet. 
5. Click Create.  
6. Type a list name using descriptive text. 
7. Click Browse to open an Excel spreadsheet that has been prepared for import - make sure you 

have defined all column headings, and place the primary field as the first column. Choose the file 
to upload, and click Open, then click Import. 

8. Enter your SharePoint account information at the prompt; in the dialog box, change Range Type 
to “Range of Cells”, clear the Select Range field, then select the cells in the spreadsheet behind the 
dialog box to define the range of cells, for example: 

           
9. Click Import, and the list will appear in SharePoint with the column headings and records. The first 

column of the selected spreadsheet will appear as the primary field in the list with a default link to 
edit the list item.  
 
Refer to “Add a List Web Part to a Page” in this guide for further instruction about displaying the list 
on a page. 
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Create a List from a List Template 
1. Click View All Site Content; navigate to a list that contains columns and/or content that you want 

to duplicate. 

2. Click the List tab; on the ribbon, click List Settings.  
3. Under Permissions and Management, select Save list as template. 
4. Enter a file name such as sample-template. 
5. Enter a template name and optional description, using mixed case text such as My Sample List 

Template. 
6. Check the box to include content (list items). 
7. Click OK; you will see a message that the template was saved to the list template gallery. Click OK 

again; you will go back to the original list settings. 

8. Click All Site Content; click . 
9. Click the List tab from the left panel section Filter By. 
10. Select My Sample List Template. (see Step 5) 
11. Enter the Name of the new list. 
12. Click More Options. Change the Navigation default to NOT display on the Quick Launch.* 
13. Click Create.        
14. The list will appear with the same columns and list settings as the original list you selected in Step 

1. 
 
*If you happen to overlook this step, the default setting will cause the new list to appear in the left 
column under a LISTS heading. To remove this, go to Site Actions > Site Settings > Look and 
Feel > Navigation. Select the Heading/folder icon Lists under Current Navigation and click Delete. 
Repeat this step to Delete the List Name from the Current Navigation. 

 

Export a List to Excel 
1. View All Site Content; navigate to a list that contains records you’d like to export to a 

spreadsheet. 
2. Click the List tab on the ribbon. 
3. Click Export to Excel. 
4. Click Open in the File Download dialog. 
5. If prompted with a security warning, click Enable. 
6. In Excel, select how the data should be imported. 
7. Click OK. 
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Delete a List or Library 
1. View All Site Content; navigate to a list or document library.  

2. Click the List or Library tab; on the ribbon, click List Settings or Library Settings.  
3. Under Permissions and Management, select Delete this list. 
4. Say OK to the message “Are you sure you want to send this list to the site Recycle Bin?” 

 

Working with Pages 

Create a New Page 
1. Navigate to the section where the page belongs. 
2. From the Site Actions menu, click View All Site Content. 
3. Navigate to the Pages library; select the Library Tools > Documents tab. 

4. Click  . 
5. Enter the page Title using mixed case text (i.e. “My Page”); Page Description is optional. 
6. The Page URL will automatically populate from the Title you entered; change this as desired to a 

compact page name like mypage.aspx. 
7. Select a page layout from the list. Refer to the DoIT SharePoint 2010 Responsive Toolkit for 

descriptions of the different page layouts 
(https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Toolkit-User-Guide.pdf). 

8. Click . 
 
 
 

Delete a Page 
1. Check the check box next to the Page name. 
2. On the Document tab, click  . 
3. Click . 

 

Restore a Deleted Page or Document 
1. Go to Recycle Bin (look on the lower left of All Site Content screen). 
2. Select the item by checking the box. 

You will only see items that have been deleted by you. 
3. Select Restore Selection. 

https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Toolkit-User-Guide.pdf
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Change a Page Layout 
1. Open a page to Edit mode. 
2. Click the Page tab on the Ribbon. 

3. Click the Page Layout button . 
4. Select a new page layout.  

NOTE: Some content could be lost if the selected page contains content in content areas that are not 
displayed in the new page layout. Refer to the DoIT SharePoint 2010 Responsive Toolkit for images of 
the different page layouts (https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-
Responsive-Design-Toolkit-User-Guide.pdf). 

 

Turn on Versioning for a Library 
1. Select the Library tab. 

2. Click  . 
3. Under General Settings, click Versioning Settings. 
4. Choose the desired versioning settings. 
5. Click . 

 

See Version History of a Page 
1. Check the check box next to the document/page name. 

2. On the Document tab, click  . 
3. To read a previous version, click on the date and time the version was created.  

 

 

View Who Has a Page Checked Out 
1. From the Site Actions menu, click View All Site Content. 
2. Navigate to the Pages Library 
3. Locate the page in question.  

The user who has the page checked out will appear in the “Checked Out To” column. 

https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Responsive-Design-Toolkit-User-Guide.pdf
https://pub.maryland.gov/sites/workspace/Shared%20Documents/2010-Responsive-Design-Toolkit-User-Guide.pdf
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Working with Web Parts 

Add a Web Part 
1. Select the Page tab. 

2. Click . 
3. On the page, click where you want the web part to appear. Web parts can be added to content 

areas OR web part zones in the branded page layouts.  
4. Select the check box of the web part or parts to add. 
5. Select the Insert tab. 

6. Click . 

7. Select the web part and click . 

 

Remove Web Parts 
1. Select the Page tab. 

2. Click . 

3. Click the  on the web part. 

4. Select . 
5. The web part will be removed from the page. 

 

Add a List Web Part to a Page 

1. Open the page where you want the list information to display; click the Edit shortcut button . 
2. On the page, click where you want the web part to appear - web parts can be added to content 

areas OR web part zones in the branded page layouts. 
a. If you want to add to a content area: click inside the content area, then Insert from the 

Editing Tools tab. Click .  
b. If you want to add to a web part zone, click Add a Web Part in any webpartzone on the 

page layout. 
3. The Lists and Libraries web parts will appear first; select the list you want to display on the page 

and click . 
4. The default list view will appear; select Edit Web Part from the dropdown on the web part header. 

The screen will blink and the Edit Panel will appear on the far right of the browser – drag the 
bottom scroll bar to the right to bring the panel into view. 
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5. Click Edit the current view to make the following changes as applicable, then click OK to close the 
Edit View screen: 

a. In the Columns section, check the Display box next to any columns you don’t want to 
display – usually Attachments and the [Primary field name] (linked to item with edit menu) 
should be unchecked. Other columns that are used for sorting or grouping may be 
unchecked as needed. 

b. Check the box to display the [Primary field name] column WITHOUT links. Change the 
Position from Left to 1. 

c. In the Sort section, select a column to sort the records. 
d. In the Tabular View section, uncheck the box Allow individual item checkboxes. 
e. In the Group By section, select a column to display the records by Groups. 
f. In the Style section, select Newsletter to display a line between list items, or Shaded to 

display shading on alternate rows of list items. 
g. In the Item Limit section, change the number of items to display, especially if your list has 

more than 30 list items. 
6. Open the page to Edit mode again; select Edit Web Part again. 
7. Change the Toolbar Type to No Toolbar. 
8. Click Appearance, scroll down through the settings, change Chrome Type to None. 
9. Click OK to close the Edit Panel; Save & Close to preview the list display on your page. 
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